All Collections
General Questions
Airtable legacy API
Error "You don't have permission to install that extension in this base."
Error "You don't have permission to install that extension in this base."

I can't install the app on Airtable. I'm unable to add it to my base "You don't have permissions to add to this base."

Updated over a week ago

⚠️This article only applies to the legacy site app.miniextensions.com

This error message is coming from Airtable. There are a few reasons for this restriction:

  1. Permissions Level: You need creator/owner permissions to add apps to your base. The error could mean you only have the access level of Editor, Commenter, or Read-Only.

  2. Enterprise: If you're on an Enterprise account, some companies block users from installing 3rd-party apps in the marketplace. The miniExtensions Sync falls under what's called custom extensions. Please check the Settings page of the Admin Panel in your organization’s Airtable account. Under Extensions, Integrations & Sync, find the option "Disable development of custom code, unless explicitly allowed".

    If it's enabled, make sure to add "[email protected]" to the developer allowlist. You might need to reach out to your account manager or Airtable Support for help.

  3. Similar Name: double-check that the selected workspace is in fact the correct one when installing the app (especially if you have multiple workspaces with the same name).

Related

Did this answer your question?